"Collection Was Modified" Error in Data Exchange Framework

  • Description

    The issue may occur with any connector using Data Exchange Framework (DEF) 2.1.0 or lower when running the pipeline batches in multiple threads. For example, if the user increases the number of threads in the Iterate Pipeline Step to some value greater than 1, the pipeline batch run may fail and cause the following error:

    24104 14:15:53 ERROR [Data Exchange] Collection was modified; enumeration operation may not execute

    All products that depend on DEF 2.1.0 or lower are affected by this issue.

  • Download and install the hotfix corresponding to your Sitecore XP and DEF version:

    See the readme file inside the archive for installation instructions.

    If you already have other hotfixes installed or need a hotfix for another Sitecore XP / DEF version, contact Sitecore Support.

Applies to:

DEF 1.0+

June 18, 2019
July 09, 2019

Reference number:

329706