Sitecore compatibility table for Sitecore XP 9.0.0 – 10.0.0

  • The following table shows the compatibility of Sitecore XP 9.0 Initial Release and later with different browsers, operating systems, .NET frameworks, and database servers.
    Compatibility data for versions prior to Sitecore XP 9.0.0 can be found in Sitecore compatibility table for Sitecore CMS 6.0 – XP 8.2.7.
    XP 9.0 XP 9.1 XP 9.2 XP 9.3 XP 10.0
    Client Browser [7]
    Microsoft Edge [4]

    Internet Explorer 11 [2]


    [11]

    [11]
    -
    Mozilla Firefox
    Google Chrome [5]
    Apple Safari [1]
    Operating System
    Windows Server 2019 - -
    [12]

    [12]

    [12]
    Windows Server 2016
    [8]
    Windows Server
    2012 R2

    - - - -
    Windows 10
    Windows 8.1
    - - - -
    .NET Framework [9]
     .NET 4.8 - - -
    .NET 4.7.2 - - -
    .NET 4.7.1 - -
    .NET 4.7 - - - -
    .NET 4.6.2
    - - - -
    ASP.NET MVC
    ASP.NET MVC 5.2
    Database Server
    MS Azure SQL [6]
    MS SQL 2019 - - -
    MS SQL 2017 -
    MS SQL 2016 SP2 -
    [10]
    -
    MS SQL 2016 SP1
    [10]
    - - - -
    MS SQL 2014 SP2 CMS-only - - - -
    MongoDB 4.0.10 - 4.0.13 - - - -
    MongoDB 4.05 - 4.0.10 - - -
    MongoDB 4.0.5 - -
    MongoDB 3.6.6
    [3]
    - - -

    Legend: "-" – not supported; "✓" – supported.
    • All product versions are valid for both 32- and 64-bit versions unless stated otherwise. Please note that some products are available only as a 64-bit version.
    • All product versions must have the latest updates or service packs installed. For specific details, refer to the Installation Guide for the corresponding XP version.
    • For information about Solr support, refer to this article: /articles/227897.
    • [1] See the Apple Safari Support article for more details.
    • [2] See the IE 11 Support known issue for more details.
    • [3] Starting from Sitecore XP 7.5 through 8.2, MongoDB was required for Sitecore xDB. Beginning with Sitecore 9.0, SQL Server support was added, while Mongo DB Support was re-added for Sitecore 9.0.2. For specific details, refer to the Installation Guide for the corresponding XP version or to the MongoDB compatibility table article.
    • [4] See the Microsoft Edge Support known issue for more details.
    • [5] Silverlight support has been deprecated for Google Chrome. See the known issue for more details.
    • [6] See the following article for Microsoft Azure SQL Databases (PaaS) compatibility: /articles/777703.
    • [7] Only the desktop versions of the listed web browsers are supported by the Sitecore Client. Browsers created for mobile operating systems, such as Android or iOS, are not supported.
    • [8] Microsoft SQL Server 2016 and Windows Server 2016 are compatible from Sitecore XP 8.2 Update-3.
    • [9] The targetFramework attribute of the httpRuntime and compilation sections must be configured according to the .NET Framework compatibility table above. The server where the Sitecore instance is hosted must have a compatible or higher version of the .NET Framework installed. Please pay attention to the fact that note #15 still applies.
    • [10] Microsoft SQL 2016 support is for Standard, Enterprise, and Express editions.
    • [11] Horizon does not work with IE11.
    • [12] Microsoft does not fully support MS ML Server installed on Windows Server 2019. More information can be found in the official MS documentation: https://docs.microsoft.com/en-us/machine-learning-server/install/r-server-install-supported-platforms.

Applies to:

CMS 9.0 Initial Release+

May 01, 2014
August 04, 2020