Updating jQuery libraries used in Sitecore Forms

  • jQuery libraries 2.1.3 that are used in Sitecore Forms 9.0–9.2 are known to be outdated.

  • To resolve this issue, consider one of the following options:
    • Upgrade Sitecore XP instance to 9.3 Initial Release or higher (recommended) as the mentioned issue does not affect Sitecore Forms 9.3.0.
      Sitecore Forms 9.3.0 contains the jQuery version 3.4.1 by default.
      Note that you can safely upgrade the jQuery 3.4.1 to 3.5.1 version as follows:
      1. Replace jquery-3.4.1.min.js with jquery-3.5.1.min.js in the "/sitecore modules/Web/ExperienceForms/scripts" folder.
      2. In the Content Editor, replace "jquery-3.4.1.min.js" with "jquery-3.5.1.min.js" in the "Scripts" field of the "/sitecore/Templates/System/Forms/Form/__Standard Values" item.
      3. Save and publish the changes.

    • For Sitecore XP 9.0 Update-1 and 9.0 Update-2, download and install the hotfix compatible with the affected product version (follow the instructions in the readme file):
      SC Hotfix 323842-1.zip (for jQuery version upgrade to 3.3.1).

      Be aware that the hotfixes were built for specific Sitecore XP versions, and you must not install them on other Sitecore XP versions or in combination with other hotfixes. If any other hotfixes have already been installed on a particular Sitecore XP instance, send a request for a compatibility check to Sitecore Support.

      Note that you must extract the ZIP file contents to locate the installation instructions and the related files inside it. You must install the hotfixes on a CM instance and then sync them with other instances using the regular development practices.
    To get a solution for other versions contact Sitecore Support.

Applies to:

Sitecore Forms 9.0 Initial Release - 9.2 Initial Release

Sitecore Forms 9.3 Initial Release

March 17, 2020
July 29, 2020

Reference number:

323526

Keywords: 

  • Sitecore Forms