Azure Search compatibility table

  • This table presents the compatibility of different Sitecore XP versions with different Azure Search API versions.

    Azure Search API XP 8.2 Update-1
    and Update-2
    XP 8.2 Update-3
    and later
    XP 9.0 XP 9.1 – 9.3
    2015-02-28-Preview [1] [5]
    2016-09-01 [2] [2] [3] [2] [3]
    2016-09-01-Preview [1] [4] [4] [4] [4]
    2017-11-11

    Legend:

    Officially tested, recommended
    No compatibility information exists or does not work
    • [1] If you choose to use the Preview API version, please be aware of the Supplemental Terms of Use for Microsoft Azure Previews:
      PREVIEWS ARE PROVIDED "AS-IS," "WITH ALL FAULTS," AND "AS AVAILABLE," AND ARE EXCLUDED FROM THE SERVICE LEVEL AGREEMENTS AND LIMITED WARRANTY. Previews may not be covered by customer support. Previews may be subject to reduced or different security, compliance and privacy commitments.
    • [2] Azure Search API 2016-09-01 does not support certain complex search queries, which can result in a NotSupportedException error.
    • [3] In order to use API version 2016-09-01, you must set the ContentSearch.Azure.UseIsMatchScoring setting to false.
    • [4] Errors similar to the following can occur on committing documents to the index:
      The property 'enabled_b' does not exist on type 'search.documentFields'. Make sure to only use property names that are defined by the type.
    • [5] 2015-02-28-preview and 2015-02-28 Azure Search API versions will be retired and no longer supported by Microsoft as of October 15, 2020. After that date, there will be no possibility to use these API versions to access Azure Search. Consider configuring Azure Search to use a newer API version (2016-09-01 or higher) according to the compatibility table.

Applies to:

CMS 8.2 Update-1+

November 06, 2017
April 21, 2020

Reference number:

213569

Keywords: 

  • Azure Module,
  • Search and Indexing