Using Social Connected 2.1 with Sitecore CMS 7.2

  • Sitecore Social Connected 2.1 is not compatible with Sitecore CMS 7.2.

    The following error message can be displayed when using the Sitecore Social Connected 2.1 module on top of Sitecore CMS 7.2:

    Could not find configuration node: contentSearch/configuration/defaultIndexConfiguration/analyzer
    1. To install the Social Connected module on Sitecore 7.2 rev. 140228:
      • Install Social Connected 2.1 rev. 140113 using the Installation Wizard. Close the error message.
      • Make required changes* to configuration files.
      • Open the Installation Wizard and install the module package again. Use the Skip option for items and files conflicts.
    2. To fix the Social Connected module that is already installed on Sitecore 7.2 rev. 140228:
      • Make required changes* to configuration files.

    * Required changes to the Sitecore.Social.config file:

    • Change the analyzer tag from:
      <analyzer ref="contentSearch/configuration/defaultIndexConfiguration/analyzer" /> 
      to:
       <analyzer ref="contentSearch/indexConfigurations/defaultLuceneIndexConfiguration/analyzer" />
    • Add the following tag to the "socialSearch/configuration" section:
      <initializeOnAdd>true</initializeOnAdd>

Applies to:

Social Connected 2, CMS 7.2

July 08, 2014
July 11, 2014

Reference number:

408378

Keywords: 

  • Social Connected