xDB Cloud Service compatibility tables

  • Compatibility for Creating New xDB Cloud Sets

    The following table presents the information about currently supported Sitecore XP releases for initializing new xDB Cloud sets.

    Sitecore XP Supported versions
    for new xDB Cloud sets
    Not supported versions
    for new xDB Cloud sets
    7.5 N/A 7.5 Initial — 7.5 Update-2
    8.0 8.0 Update-6 — 8.0 Update-7 8.0 Initial — 8.0 Update-5
    8.1 8.1 Update-1 — 8.1 Update-3 8.1 Initial Release
    8.2 8.2 Initial Release — 8.2 Update-3 N/A

    Important notes:
    • All new xDB Cloud sets are created using xDB Cloud 2.0. You can read more about it on doc.sitecore.net.
    • For xDB Cloud to work properly, the Content Delivery and Content Management instances version must exactly match the xDB Cloud version.
    • This section describes Sitecore XP versions available for creating new xDB Cloud sets. For the list of available target versions for upgrading xDB Cloud, see the next section in this article.
  • Compatibility for Upgrading Existing xDB Cloud Sets

    The following table represents supported upgrade options for xDB Cloud sets. When planning an upgrade, ensure that the target version is in the table:

    Source version Target version
    7.5 Initial Release — 7.5 Update-2 8.0 Update-7
    8.0 Initial Release  8.0 Update-6 8.0 Update-7
    8.0 Initial Release — 8.0 Update-7
    8.1 Initial Release — 8.1 Update-1
    8.1 Update-2 or 8.1 Update-3
    8.1 Update-2 8.1 Update-3
    8.1 Update-3 8.2 Initial Release
    8.2 Initial Release 8.2 Update-1
    8.2 Update-1 8.2 Update-2
    8.2 Update-2 8.2 Update-3


    Note: For planning the overall Sitecore XP upgrade process together with xDB Cloud, refer to How to Upgrade xDB Cloud article.

  • Compatible xDB Cloud Client Versions

    To ensure a stable connection to xDB Cloud, the latest compatible updates of xDB Cloud Client package must be installed on all Sitecore Content Delivery (CD) and Content Management (CM) instances. Refer to the following tables for compatibility information.

    For xDB Cloud 1.0:

    Sitecore XP xDB Cloud Client Version Compatible Sitecore XP Versions
    7.5 Sitecore xDB Cloud 7.5 rev. 160210 7.5 Initial Release — 7.5 Update-2
    8.0 Sitecore xDB Cloud 8.0 rev. 160210 8.0 Initial Release — 8.0 Update-7
    8.1 Sitecore xDB Cloud 8.1 rev. 160210 8.1 Initial Release — 8.1 Update-3

    For xDB Cloud 2.0:

    Sitecore XP xDB Cloud Client Version Compatible Sitecore XP Versions
    8.0 Sitecore xDB Cloud 8.0 rev. 160721 8.0 Update-6 — 8.0 Update-7
    8.1 Sitecore xDB Cloud 8.1 rev. 160721 8.1 Update-1 — 8.1 Update-3
    8.2 Sitecore xDB Cloud 8.2 rev. 160623 (out-of-the-box) 8.2 Initial Release
    Sitecore xDB Cloud 8.2 rev. 170223 8.2 Update-1 — 8.2 Update-3

    Note: xDB Cloud 2.0 is supported only for new xDB Sets that are provisioned using a corresponding Sitecore XP version. Existing xDB Cloud 1.0 sets can be migrated to xDB Cloud 2.0 on-demand using the following process: https://kb.sitecore.net/articles/274380.

  • Compatible Data Center locations

    New xDB Cloud sets can be provisioned in the following geographical locations:

    • Australia East
    • Canada Central
    • Central India
    • East Asia
    • East US
    • Japan West
    • North Central US
    • North Europe
    • South Central US
    • South UK
    • Southeast Asia
    • West Europe
    • West US
    • Brazil South
  • Compatible MongoDB versions

    The following table presents the information about currently available MongoDB server versions in xDB Cloud.

    Default
    (used for new sets)
    Supported versions Not supported versions
    3.0 MMAPv1 2.6 MMAPv1, 3.0 MMAPv1, 3.2 MMAPv1,
    3.2 WiredTiger
    3.0 WiredTiger


    Important note: Read more about Sitecore XP and MongoDB compatibility here: https://kb.sitecore.net/articles/633863.

  • Compatible Sitecore Modules

    The following table presents the compatibility of the xDB Cloud service with different Sitecore modules or components:

    Module / Component Compatible Versions Not Compatible Versions
    Email Experience Manager 8.0 Update-3 — 8.2 Initial Release
    EXM 3.1 and higher
    Prior to 8.0 Update-3
    8.2 Update-1 — 8.2 Update-2
    Web Forms for Marketers All Sitecore Releases N/A
    Experience Profile All Sitecore Releases N/A
    Experience Analytics All Sitecore Releases [1] N/A
    Experience Explorer All Sitecore Releases N/A
    Federated Experience Manager All Sitecore Releases N/A
    List Manager All Sitecore Releases N/A
    Path Analyzer 8.0 Update-4 and higher [2] Prior to 8.0 Update-4
    Sitecore Content Testing All Sitecore Releases N/A
    Sitecore Social All Sitecore Releases N/A
     User to Contact Conversion Tool N/A All Sitecore Releases
    • All module versions or components assume that they are compatible with the appropriate CMS/XP version. For specific details, refer to Sitecore Modules Compatibility table.
    • [1] Creation of custom segments is not supported by the Experience Analytics in the xDB Cloud service. This should be fixed in a future service update.
    • [2] The Path Analyzer does not support the admin page (/sitecore/admin/pathanalyzer.aspx) or the standard historic rebuild with xDB Cloud service, but is expected to with one of the future Sitecore releases.

Applies to:

CMS 7.5+

August 25, 2015
June 09, 2017

Keywords: 

  • App Center
  • ,
  • ECM
  • ,
  • Experience Explorer
  • ,
  • Federated Experience Manager
  • ,
  • Path Analyzer
  • ,
  • Web Forms for Marketers
  • ,
  • XDB