Sitecore Forms are not displayed in the Forms application

  • The created forms may not be displayed when opening the Forms application. There are three possible scenarios that may result in such behavior:

    • isTemplate field is not added to the sitecore_master_index.
    • The form version does not exist in the Sitecore Client UI language.
    • SXA computed field breaks indexing functionality.

    The following is a detailed descriptions of each scenario, including the solution.

  • Sitecore forms might not be displayed because some form fields are not included in the index and are therefore missing. For example, the required /sitecore/templates/System/Forms/Form/Settings/Is Template field is not added to the sitecore_master_index search index when the indexAllFields setting is set to false.

    Solution:
  • Forms not created in the Sitecore Client UI language are not displayed in the Forms application. The search uses the context language, specified in the ClientLanguage setting.

    Solution:

    This issue has been fixed in Sitecore XP 9.0 rev. 180604 (Update-2).

  • In SXA 1.7 or lower, the incorrect returned type of the computed field level causes an exception. ComputeFieldValue method may return false instead of int, which leads to an indexing error. For example, the following error message can be displayed when using Solr search engine:

    org.apache.solr.common.SolrException: ERROR: [doc=visit|e2dabf69-23ff-4b97-a284-4574d5771849] Error adding field 'level_tl'='false' msg=For input string: "false"

    Solution:

    This issue has been fixed in SXA 1.8.

Applies to:

CMS 9.0 Initial Release - 9.2 Initial Release

CMS 9.3 Initial Release

May 29, 2019
November 28, 2019

Reference number:

229445, 331742, 176412, 195041, 242970, 13290