Sitecore 8.2.x support for MongoDb 3.6

  • Description

    MongoDb 3.4 will reach end of life support in January 2020 (as stated here). Currently Sitecore XP 8.2 is compatible with MongoDb 3.4. Customers using Sitecore XP 8.2 must upgrade to MongoDb version 3.6.

  • The following upgrade process has been tested with MongoDb 3.6.6.

    Prerequisite:

    Customers using Sitecore XP versions earlier than 8.2.7 must upgrade to Sitecore XP 8.2.7.

    Update procedure:

    1. Download the following archive: CSharpDriver-2.5.0.zip.
    2. Extract the following assemblies from the \net45 folder inside the archive:
      • MongoDB.Bson.dll
      • MongoDB.Driver.Core.dll
      • MongoDB.Driver.dll
      • MongoDB.Driver.Legacy.dll
    3. Overwrite MongoDB driver assemblies in all your Sitecore XP instances (located in the \bin folder) with the assemblies mentioned in the previous step.

    Please contact Sitecore Support in case of any issues.

Applies to:

CMS 8.2

August 05, 2019
August 05, 2019