Azure Cognitive Search API Deprecation

  • The following versions of the Azure Cognitive Search REST API will be retired by Microsoft and no longer supported starting from 15 January 2021:
    • 2014-07-31-Preview
    • 2014-10-20-Preview
    • 2015-02-28-Preview
    • 2015-02-28

    This will affect Sitecore XP 9.0 Initial Release and Sitecore 9.0 Update-1 solutions on Azure using PAAS installations and Azure Search.

    For more information about API versions in Azure Cognitive Search, refer to the following link:
    https://docs.microsoft.com/en-us/azure/search/search-api-versions

  • To resolve the issue, consider the following options:
    • Upgrade Sitecore XP instance to Sitecore XP 9.0.2 or later in order to use the later version of the Azure Cognitive Search REST API.
    • Download and install the hotfix compatible with the affected product version found on this page:

    Be aware that the hotfix was built for a specific Sitecore XP version, and must not be installed on other Sitecore XP versions or in combination with other hotfixes. In case any other hotfixes have already been installed on a certain Sitecore XP instance, send a request for a compatibility check to Sitecore Support.

    Note that the ZIP file contents need to be extracted to locate installation instructions and related files inside. The hotfixes must be installed on a CM instance and then synced with other instances using standard development practices.

Applies to:

CMS 9.0 Initial Release - 9.0 Update-1

CMS 9.0 Update-2

January 05, 2021
January 08, 2021

Reference number:

452326, 454069, 454070

Keywords: 

  • Azure Search