Performance issues when item cloning is enabled

  • When the item cloning feature is enabled on a solution, a user might experience performance issues. Basic user operations such as creating or loading items can be affected by this issue.
  • To resolve the issue, consider one of the following options:
    • Upgrade Sitecore XP instance to Sitecore XP 10.1.0.
    • Download and install the hotfix compatible with the affected product version:
    • Disable the item cloning feature:
      • To check if item clones are not used on a solution, see the following article: How to verify whether the item cloning feature is used.
      • To disable item clones, change the value of the following setting from "true" to "false":
      • <setting name="ItemCloning.Enabled" value="true"/>

    Be aware that hotfixes were built for specific Sitecore XP versions, and must not be installed on other Sitecore XP versions or in combination with other hotfixes. In case any other hotfixes have already been installed on a certain Sitecore XP instance, send a request for a compatibility check to Sitecore Support.
    Note that the ZIP file contents need to be extracted to locate installation instructions and related files inside. The hotfixes must be installed on a CM instance and then synced with other instances using standard development practices.

Applies to:

CMS 9.3 Initial Release - 10.0 Update-1

CMS 10.1 Initial Release

February 16, 2021
February 25, 2021

Reference number:

442879

Keywords: 

  • Performance